2019年全国高校程序设计挑战赛JAVA编程题5

2019年全国高校程序设计挑战赛JAVA编程题5

2019年全国高校程序设计挑战赛JAVA编程题5

编程描述

给定4只包含0-9、 +、 * 的合法数学表达式(长度<1000),规定加’的优先级高于乘号 ,请输出计算结果。

输入格式

合法的数学表达式

输出格式

输出表达式的计算结果

输入样例

1
12*3+12*2 

输出样例

1
360

算法实现

Java(jdk1.7)

代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
import java.util.Scanner;
import java.util.Stack;

public class Main {
public static Scanner sc = new Scanner(System.in);

public static void main(String[] args) {
String input = sc.nextLine();
sc.close();

double result1 = compute(input);
System.out.println((int) result1);
}

public static int priority(char s) {
switch (s) {
case '+':
return 2;
case '*':
return 1;
default:
return -1;
}
}

public static double compute(double num1, double num2, char s) {
switch (s) {
case '+':
return num1 + num2;
case '*':
return num1 * num2;
default:
return 0;

}
}

public static double compute(String str) {
double num[] = new double[20];
int flag = 0, begin = 0, end = 0, now;
now = -1;
Stack<Character> st = new Stack<Character>();
for (int i = 0; i < str.length(); i++) {
char s = str.charAt(i);
if (s == ' ') {

} else if (s == '+' || s == '*') {
if (flag == 1) {
now += 1;
if (end < begin) {
num[now] = Integer.valueOf(str.substring(begin, begin + 1));
} else {
num[now] = Integer.valueOf(str.substring(begin, end + 1));
}
flag = 0;
}
if (s == '-') {
if (i == 0) {
flag = 1;
begin = 0;
} else if (str.charAt(i - 1) == '(' || str.charAt(i - 1) == '*' || str.charAt(i - 1) == '/') {
flag = 1;
begin = i;
} else {
if (st.empty()) {
st.push(s);
} else if (s == ')') {
num[now - 1] = compute(num[now - 1], num[now], st.pop());
now -= 1;
st.pop();
} else if (s == '(') {
st.push(s);
} else if (priority(s) <= priority(st.peek())) {
num[now - 1] = compute(num[now - 1], num[now], st.pop());
now -= 1;
st.push(s);
} else {
st.push(s);
}
}
} else if (st.empty()) {
st.push(s);
} else if (s == ')') {
num[now - 1] = compute(num[now - 1], num[now], st.pop());
now -= 1;
st.pop();
} else if (s == '(') {
st.push(s);
} else if (priority(s) <= priority(st.peek())) {
num[now - 1] = compute(num[now - 1], num[now], st.pop());
now -= 1;
st.push(s);
} else {
st.push(s);
}

} else if (flag == 0) {
flag = 1;
begin = i;
} else {
end = i;
}

}
if (flag == 1) {
now += 1;
if (end < begin) {
num[now] = Integer.valueOf(str.substring(begin, begin + 1));
} else {
num[now] = Integer.valueOf(str.substring(begin, end + 1));
}
}
while (now > 0) {
num[now - 1] = compute(num[now - 1], num[now], st.pop());
now -= 1;
}
return num[0];
}
}
文章作者: HibisciDai
文章链接: http://hibiscidai.com/2019/11/21/2019-11-21-2019年全国高校程序设计挑战赛JAVA编程题5/
版权声明: 本博客所有文章除特别声明外,均采用 CC BY-NC-SA 4.0 许可协议。转载请注明来自 HibisciDai
好用、实惠、稳定的梯子,点击这里